Subject: Re: [REGRESSION FIX resend 1/1] gpiolib: acpi: Make set debounce errors non fatal

From: Andy Shevchenko <[email-masked]>
Date: Thu, 23 Oct 2025 09:39:35 +0300

On Wed, Oct 22, 2025 at 04:47:34PM +0300, Andy Shevchenko wrote:
> On Wed, Oct 22, 2025 at 4:37 PM Hans de Goede <[email-masked]> wrote:
> >
> > Commit 16c07342b542 ("gpiolib: acpi: Program debounce when finding GPIO")
> > adds a gpio_set_debounce_timeout() call to acpi_find_gpio() and makes
> > acpi_find_gpio() fail if this fails.
> >
> > But gpio_set_debounce_timeout() failing is a somewhat normal occurrence,
> > since not all debounce values are supported on all GPIO/pinctrl chips.
> >
> > Making this an error for example break getting the card-detect GPIO for
> > the micro-sd slot found on many Bay Trail tablets, breaking support for
> > the micro-sd slot on these tablets.
> >
> > acpi_request_own_gpiod() already treats gpio_set_debounce_timeout()
> > failures as non-fatal, just warning about them.
> >
> > Add a acpi_gpio_set_debounce_timeout() helper which wraps
> > gpio_set_debounce_timeout() and warns on failures and replace both existing
> > gpio_set_debounce_timeout() calls with the helper.
> >
> > Since the helper only warns on failures this fixes the card-detect issue.
> 
> Acked-by: Andy Shevchenko <[email-masked]>
> if Bart wants to take this directly.

Never mind, it seems we gotta fix an LKP thingy, I'm about to send a PR out of
two patches.

-- 
With Best Regards,
Andy Shevchenko

---

From: Andy Shevchenko <[email-masked]>
Date: Wed, 22 Oct 2025 16:47:34 +0300

-- 
With Best Regards,
Andy Shevchenko

---

From: Hans de Goede <[email-masked]>
Date: Wed, 22 Oct 2025 15:37:15 +0200

Fixes: 16c07342b542 ("gpiolib: acpi: Program debounce when finding GPIO")
Cc: [email-masked]
Cc: Mario Limonciello <[email-masked]>
Signed-off-by: Hans de Goede <[email-masked]>
---
 drivers/gpio/gpiolib-acpi-core.c | 27 +++++++++++++++------------
 1 file changed, 15 insertions(+), 12 deletions(-)

diff --git a/drivers/gpio/gpiolib-acpi-core.c b/drivers/gpio/gpiolib-acpi-core.c
index 284e762d92c4..67c4c38afb86 100644
--- a/drivers/gpio/gpiolib-acpi-core.c
+++ b/drivers/gpio/gpiolib-acpi-core.c
@@ -291,6 +291,19 @@ acpi_gpio_to_gpiod_flags(const struct acpi_resource_gpio *agpio, int polarity)
 	return GPIOD_ASIS;
 }
 
+static void acpi_gpio_set_debounce_timeout(struct gpio_desc *desc,
+					   unsigned int acpi_debounce)
+{
+	int ret;
+
+	/* ACPI uses hundredths of milliseconds units */
+	acpi_debounce *= 10;
+	ret = gpio_set_debounce_timeout(desc, acpi_debounce);
+	if (ret)
+		gpiod_warn(desc, "Failed to set debounce-timeout %u: %d\n",
+			   acpi_debounce, ret);
+}
+
 static struct gpio_desc *acpi_request_own_gpiod(struct gpio_chip *chip,
 						struct acpi_resource_gpio *agpio,
 						unsigned int index,
@@ -300,18 +313,12 @@ static struct gpio_desc *acpi_request_own_gpiod(struct gpio_chip *chip,
 	enum gpiod_flags flags = acpi_gpio_to_gpiod_flags(agpio, polarity);
 	unsigned int pin = agpio->pin_table[index];
 	struct gpio_desc *desc;
-	int ret;
 
 	desc = gpiochip_request_own_desc(chip, pin, label, polarity, flags);
 	if (IS_ERR(desc))
 		return desc;
 
-	/* ACPI uses hundredths of milliseconds units */
-	ret = gpio_set_debounce_timeout(desc, agpio->debounce_timeout * 10);
-	if (ret)
-		dev_warn(chip->parent,
-			 "Failed to set debounce-timeout for pin 0x%04X, err %d\n",
-			 pin, ret);
+	acpi_gpio_set_debounce_timeout(desc, agpio->debounce_timeout);
 
 	return desc;
 }
@@ -944,7 +951,6 @@ struct gpio_desc *acpi_find_gpio(struct fwnode_handle *fwnode,
 	bool can_fallback = acpi_can_fallback_to_crs(adev, con_id);
 	struct acpi_gpio_info info = {};
 	struct gpio_desc *desc;
-	int ret;
 
 	desc = __acpi_find_gpio(fwnode, con_id, idx, can_fallback, &info);
 	if (IS_ERR(desc))
@@ -959,10 +965,7 @@ struct gpio_desc *acpi_find_gpio(struct fwnode_handle *fwnode,
 	acpi_gpio_update_gpiod_flags(dflags, &info);
 	acpi_gpio_update_gpiod_lookup_flags(lookupflags, &info);
 
-	/* ACPI uses hundredths of milliseconds units */
-	ret = gpio_set_debounce_timeout(desc, info.debounce * 10);
-	if (ret)
-		return ERR_PTR(ret);
+	acpi_gpio_set_debounce_timeout(desc, info.debounce);
 
 	return desc;
 }
-- 
2.51.0