Subject: Re: [PATCH] rust: device: fix device context of Device::parent()

From: Alice Ryhl <[email-masked]>
Date: Fri, 17 Oct 2025 13:07:03 +0000

On Thu, Oct 16, 2025 at 03:31:44PM +0200, Danilo Krummrich wrote:
> Regardless of the DeviceContext of a device, we can't give any
> guarantees about the DeviceContext of its parent device.
> 
> This is very subtle, since it's only caused by a simple typo, i.e.
> 
> 	 Self::from_raw(parent)
> 
> which preserves the DeviceContext in this case, vs.
> 
> 	 Device::from_raw(parent)
> 
> which discards the DeviceContext.
> 
> (I should have noticed it doing the correct thing in auxiliary::Device
> subsequently, but somehow missed it.)
> 
> Hence, fix both Device::parent() and auxiliary::Device::parent().
> 
> Cc: [email-masked]
> Fixes: a4c9f71e3440 ("rust: device: implement Device::parent()")
> Signed-off-by: Danilo Krummrich <[email-masked]>

Reviewed-by: Alice Ryhl <[email-masked]>

---

From: "Alexandre Courbot" <[email-masked]>
Date: Fri, 17 Oct 2025 11:55:07 +0900

> Signed-off-by: Danilo Krummrich <[email-masked]>

Ouch, that will make me think twice the next time I consider using
`Self` for convenience... :)

Reviewed-by: Alexandre Courbot <[email-masked]>

---

From: Danilo Krummrich <[email-masked]>
Date: Thu, 16 Oct 2025 15:31:44 +0200

Self::from_raw(parent)

	 Device::from_raw(parent)

Cc: [email-masked]
Fixes: a4c9f71e3440 ("rust: device: implement Device::parent()")
Signed-off-by: Danilo Krummrich <[email-masked]>
---
 rust/kernel/auxiliary.rs | 8 +-------
 rust/kernel/device.rs    | 4 ++--
 2 files changed, 3 insertions(+), 9 deletions(-)

diff --git a/rust/kernel/auxiliary.rs b/rust/kernel/auxiliary.rs
index 4163129b4103..e12f78734606 100644
--- a/rust/kernel/auxiliary.rs
+++ b/rust/kernel/auxiliary.rs
@@ -217,13 +217,7 @@ pub fn id(&self) -> u32 {
 
     /// Returns a reference to the parent [`device::Device`], if any.
     pub fn parent(&self) -> Option<&device::Device> {
-        let ptr: *const Self = self;
-        // CAST: `Device<Ctx: DeviceContext>` types are transparent to each other.
-        let ptr: *const Device = ptr.cast();
-        // SAFETY: `ptr` was derived from `&self`.
-        let this = unsafe { &*ptr };
-
-        this.as_ref().parent()
+        self.as_ref().parent()
     }
 }
 
diff --git a/rust/kernel/device.rs b/rust/kernel/device.rs
index 23a95324cb0f..343996027c89 100644
--- a/rust/kernel/device.rs
+++ b/rust/kernel/device.rs
@@ -256,7 +256,7 @@ pub(crate) fn as_raw(&self) -> *mut bindings::device {
 
     /// Returns a reference to the parent device, if any.
     #[cfg_attr(not(CONFIG_AUXILIARY_BUS), expect(dead_code))]
-    pub(crate) fn parent(&self) -> Option<&Self> {
+    pub(crate) fn parent(&self) -> Option<&Device> {
         // SAFETY:
         // - By the type invariant `self.as_raw()` is always valid.
         // - The parent device is only ever set at device creation.
@@ -269,7 +269,7 @@ pub(crate) fn parent(&self) -> Option<&Self> {
             // - Since `parent` is not NULL, it must be a valid pointer to a `struct device`.
             // - `parent` is valid for the lifetime of `self`, since a `struct device` holds a
             //   reference count of its parent.
-            Some(unsafe { Self::from_raw(parent) })
+            Some(unsafe { Device::from_raw(parent) })
         }
     }
 
-- 
2.51.0

---

From: Greg KH <[email-masked]>
Date: Thu, 16 Oct 2025 15:47:30 +0200

>  2 files changed, 3 insertions(+), 9 deletions(-)

Acked-by: Greg Kroah-Hartman <[email-masked]>