Subject: Re: [PATCH 1/2] media: i2c: imx219: Fix 1920x1080 mode to use 1:1 pixel aspect ratio

From: Jacopo Mondi <[email-masked]>
Date: Fri, 17 Oct 2025 11:23:46 +0200

Hi Jai

On Fri, Oct 17, 2025 at 01:43:49PM +0530, Jai Luthra wrote:
> From: Dave Stevenson <[email-masked]>
>
> Commit 0af46fbc333d ("media: i2c: imx219: Calculate crop rectangle
> dynamically") meant that the 1920x1080 mode switched from using no
> binning to using vertical binning but no horizontal binning, which
> resulted in stretched pixels.
>
> Until proper controls are available to independently select horizontal
> and vertical binning, restore the original 1:1 pixel aspect ratio by
> forcing binning to be uniform in both directions.

I think it makes sense and I wonder if binning in one direction and
not in the other will ever be needed in the general case.

For this driver indeed, this fixes a visible regression
Reviewed-by: Jacopo Mondi <[email-masked]>

Thanks
  j
>
> Cc: [email-masked]
> Fixes: 0af46fbc333d ("media: i2c: imx219: Calculate crop rectangle dynamically")
> Signed-off-by: Dave Stevenson <[email-masked]>
> [Add comment & reword commit message]
> Signed-off-by: Jai Luthra <[email-masked]>
> ---
>  drivers/media/i2c/imx219.c | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/media/i2c/imx219.c b/drivers/media/i2c/imx219.c
> index c680aa6c3a55a9d865e79ad337b258cb681f98fe..300935b1ef2497050fe2808e4ceedda389a75b50 100644
> --- a/drivers/media/i2c/imx219.c
> +++ b/drivers/media/i2c/imx219.c
> @@ -856,7 +856,7 @@ static int imx219_set_pad_format(struct v4l2_subdev *sd,
>  	const struct imx219_mode *mode;
>  	struct v4l2_mbus_framefmt *format;
>  	struct v4l2_rect *crop;
> -	u8 bin_h, bin_v;
> +	u8 bin_h, bin_v, binning;
>  	u32 prev_line_len;
>
>  	format = v4l2_subdev_state_get_format(state, 0);
> @@ -877,9 +877,12 @@ static int imx219_set_pad_format(struct v4l2_subdev *sd,
>  	bin_h = min(IMX219_PIXEL_ARRAY_WIDTH / format->width, 2U);
>  	bin_v = min(IMX219_PIXEL_ARRAY_HEIGHT / format->height, 2U);
>
> +	/* Ensure bin_h and bin_v are same to avoid 1:2 or 2:1 stretching */
> +	binning = min(bin_h, bin_v);
> +
>  	crop = v4l2_subdev_state_get_crop(state, 0);
> -	crop->width = format->width * bin_h;
> -	crop->height = format->height * bin_v;
> +	crop->width = format->width * binning;
> +	crop->height = format->height * binning;
>  	crop->left = (IMX219_NATIVE_WIDTH - crop->width) / 2;
>  	crop->top = (IMX219_NATIVE_HEIGHT - crop->height) / 2;
>
>
> --
> 2.51.0
>

---

From: Jai Luthra <[email-masked]>
Date: Fri, 17 Oct 2025 13:43:48 +0530

This series fixes a regression introduced in commit 0af46fbc333d
("media: i2c: imx219: Calculate crop rectangle dynamically") that
started using vertical binning for 1920x1080 without binning
horizontally, causing the captured images to be stretched in one
dimension.

In a subsequent patch, simplify the binning mode calculation logic as
well. This is done separately, without a fixes tag, as it is cleaning up
code that was introduced much later to the regression commit, and
doesn't strictly require backporting.

Once Sakari's metadata series with binning controls [1] is merged, this
and other existing sensor drivers may be extended to support free
configuration of resolution, and give the userspace freedom to bin
pixels in only one dimension if required, of course, as long as it
doesn't cause regressions with exsiting userspace applications.

[1]: https://lore.kernel.org/all/[email-masked]/

Signed-off-by: Jai Luthra <[email-masked]>
---
Dave Stevenson (1):
      media: i2c: imx219: Fix 1920x1080 mode to use 1:1 pixel aspect ratio

Jai Luthra (1):
      media: i2c: imx219: Simplify imx219_get_binning() function

 drivers/media/i2c/imx219.c | 25 +++++++++----------------
 1 file changed, 9 insertions(+), 16 deletions(-)
---
base-commit: 3a8660878839faadb4f1a6dd72c3179c1df56787
change-id: 20251016-imx219-1080p-ad3fbdce70d1

Best regards,
-- 
Jai Luthra <[email-masked]>

---

From: Jai Luthra <[email-masked]>
Date: Fri, 17 Oct 2025 13:43:49 +0530

-- 
2.51.0