Subject: Re: [PATCH net] net: stmmac: dwmac-rk: Fix disabling set_clock_selection

From: [email-masked]
Date: Fri, 17 Oct 2025 01:50:06 +0000

Hello:

This patch was applied to netdev/net.git (main)
by Jakub Kicinski <[email-masked]>:

On Tue, 14 Oct 2025 17:49:34 +0200 you wrote:
> On all platforms set_clock_selection() writes to a GRF register. This
> requires certain clocks running and thus should happen before the
> clocks are disabled.
> 
> This has been noticed on RK3576 Sige5, which hangs during system suspend
> when trying to suspend the second network interface. Note, that
> suspending the first interface works, because the second device ensures
> that the necessary clocks for the GRF are enabled.
> 
> [...]

Here is the summary with links:
  - [net] net: stmmac: dwmac-rk: Fix disabling set_clock_selection
    https://git.kernel.org/netdev/net/c/7f864458e9a6

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

---

From: Simon Horman <[email-masked]>
Date: Thu, 16 Oct 2025 13:44:12 +0100

On Tue, Oct 14, 2025 at 05:49:34PM +0200, Sebastian Reichel wrote:
> Cc: [email-masked]
> Fixes: 2f2b60a0ec28 ("net: ethernet: stmmac: dwmac-rk: Add gmac support for rk3588")
> Signed-off-by: Sebastian Reichel <[email-masked]>

Reviewed-by: Simon Horman <[email-masked]>