Subject: Re: [PATCH] s390/uv: Fix the comment of the uv_find_secret() function

From: Claudio Imbrenda <[email-masked]>
Date: Thu, 2 Oct 2025 18:24:56 +0200

On Thu,  2 Oct 2025 17:54:23 +0200
Thomas Huth <[email-masked]> wrote:

> From: Thomas Huth <[email-masked]>
> 
> The uv_get_secret_metadata() function has been removed some
> months ago, so we should not mention it in the comment anymore.
> 
> Fixes: a42831f0b74dc ("s390/uv: Remove uv_get_secret_metadata function")
> Signed-off-by: Thomas Huth <[email-masked]>

Acked-by: Claudio Imbrenda <[email-masked]>

> ---
>  arch/s390/kernel/uv.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/s390/kernel/uv.c b/arch/s390/kernel/uv.c
> index 47f574cd1728a..324cd549807a5 100644
> --- a/arch/s390/kernel/uv.c
> +++ b/arch/s390/kernel/uv.c
> @@ -866,8 +866,8 @@ static int find_secret_in_page(const u8 secret_id[UV_SECRET_ID_LEN],
>  	return -ENOENT;
>  }
>  
> -/*
> - * Do the actual search for `uv_get_secret_metadata`.
> +/**
> + * uv_find_secret() - search secret metadata for a given secret id.
>   * @secret_id: search pattern.
>   * @list: ephemeral buffer space
>   * @secret: output data, containing the secret's metadata.

---

From: Thomas Huth <[email-masked]>
Date: Thu, 2 Oct 2025 17:54:23 +0200

-/*
-- 
2.51.0