Subject: Re: Please backport commit a40282dd3c48 ("gcc-plugins: Remove TODO_verify_il for GCC >= 16")

From: Kees Cook <[email-masked]>
Date: Fri, 3 Oct 2025 17:31:04 -0700

On Fri, Oct 03, 2025 at 03:02:52PM +0200, Greg KH wrote:
> On Wed, Oct 01, 2025 at 08:10:58AM -0700, Kees Cook wrote:
> > Hi,
> > 
> > Please backport:
> > 
> >   commit a40282dd3c48 ("gcc-plugins: Remove TODO_verify_il for GCC >= 16")
> > 
> > to all stable kernel versions. This prepares the GCC plugins for the
> > coming GCC 16 release.
> 
> Now queued up for 6.1 and newer trees, it didn't apply to 5.15 and
> older.

Great; thank you! :)

-- 
Kees Cook

---

From: Greg KH <[email-masked]>
Date: Fri, 3 Oct 2025 15:02:52 +0200

thanks,

greg k-h

---

From: Kees Cook <[email-masked]>
Date: Wed, 1 Oct 2025 08:10:58 -0700

Hi,

Please backport:

Thanks!

-Kees

-- 
Kees Cook