Subject: Re: S/PDIF not detected anymore / regression on recent kernel 6.7 ?

From: Serge SIMON <[email-masked]>
Date: Fri, 3 Oct 2025 21:17:39 +0200

So i've just tested this, and ... you were definitely correct / on the
good track.

Once back with 6.10.16 + that "snd_hda_core.gpu_bind=0" kernel parameter :
- my S/PDIF output is detected again (and is working as before)
- surprisingly, it seems i'm not able to select the HDMI outputs (of
the monitors) under GNOME settings (i now only have the S/PDIF entry)
... however a "cat /proc/asound/pcm" is correct, and is showing
everything ... but to be honest, i just don't care (the point was to
not use the (crappy) monitor sound outputs)

Extra information :
- indeed i was bypassing the iGPU (also activated at BIOS level) to some VM
- by the way, i also had the "intel_iommu=on" parameter at kernel level
- latest dmesg from today (for reference / just in case) :
https://gist.github.com/SR-G/ef22e46e96bfb300c3689cf8ea073098#file-dmesg-6-10-16-log
- current "cat /proc/asounc/pcm" is back to :
00-00: ALC1220 Analog : ALC1220 Analog : playback 1 : capture 1
00-01: ALC1220 Digital : ALC1220 Digital : playback 1
00-02: ALC1220 Alt Analog : ALC1220 Alt Analog : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 1 : HDMI 1 : playback 1
01-08: HDMI 2 : HDMI 2 : playback 1
01-09: HDMI 3 : HDMI 3 : playback 1

So a big thank you for your analysis and for having taken the time to
investigate into this !

-- 
Serge.

On Fri, Oct 3, 2025 at 8:32 PM Alexander Tsoy <[email-masked]> wrote:
>
> В Пт, 03/10/2025 в 17:57 +0300, Alexander Tsoy пишет:
> > В Пт, 03/10/2025 в 15:20 +0200, Serge SIMON пишет:
> > > Hello,
> > >
> > > I still encounter this issue (and every month i test the latest
> > > kernel, each time with the same results) :
> > > - i do have an ASUS B560-I WIFI (ITX) motherboard with a S/PDIF
> > > output
> > > - everything was working flawlessly until (and including) kernel
> > > 6.6.10, and that S/PDIF output was perfectly detected (under GNOME
> > > SHELL, etc.)
> > > - starting from kernel 6.7.0 (and newest ones, including 6.16.10
> > > tested today) the S/PDIF output it NOT detected anymore at boot
> > > time
> > > by the kernel (so is not selectable any more under GNOME SHELL or
> > > COSMIC, etc.)
> > >
> > > With old kernel (example :
> > > https://gist.github.com/SR-G/0e86d917716acff0d31cad0365f0b500#file-gistfile1-txt
> > > )
> > > :
> > >
> > > % cat /proc/asound/pcm
> > >
> > > 00-00: ALC1220 Analog : ALC1220 Analog : playback 1 : capture 1
> > > 00-01: ALC1220 Digital : ALC1220 Digital : playback 1
> > > 00-02: ALC1220 Alt Analog : ALC1220 Alt Analog : capture 1
> > > 01-03: HDMI 0 : HDMI 0 : playback 1
> > > 01-07: HDMI 1 : HDMI 1 : playback 1
> > > 01-08: HDMI 2 : HDMI 2 : playback 1
> > > 01-09: HDMI 3 : HDMI 3 : playback 1
> > >
> > >
> > > With kernels >= 6.7.0 (example :
> > > https://gist.github.com/SR-G/0e86d917716acff0d31cad0365f0b500#file-dmesg-6-12-6-log
> > > )
> > > :
> >
> > Did you disable intel iGPU somehow? Try to add
> > snd_hda_core.gpu_bind=0
> > to the kernel cmdline.
> >
>
> Ah, I see:
> ...
> vfio_pci: add [8086:4c8a[ffffffff:ffffffff]] class 0x000000/00000000
> ...
>
> You probably passthrough the GPU to VM so the i915 driver is not loaded
> on the host. Thus you really need snd_hda_core.gpu_bind=0 kernel
> option. This is a consequence of the following series:
> https://lore.kernel.org/all/[email-masked]/

---

From: Alexander Tsoy <[email-masked]>
Date: Fri, 03 Oct 2025 21:32:33 +0300

Ah, I see:
...

---

From: Alexander Tsoy <[email-masked]>
Date: Fri, 03 Oct 2025 17:57:05 +0300

В Пт, 03/10/2025 в 15:20 +0200, Serge SIMON пишет:
> tested today) the S/PDIF output it NOT detected anymore at boot time

Did you disable intel iGPU somehow? Try to add snd_hda_core.gpu_bind=0
to the kernel cmdline.

---

From: Serge SIMON <[email-masked]>
Date: Fri, 3 Oct 2025 15:20:38 +0200

Hello,

- i do have an ASUS B560-I WIFI (ITX) motherboard with a S/PDIF output

With old kernel (example :
https://gist.github.com/SR-G/0e86d917716acff0d31cad0365f0b500#file-gistfile1-txt)
:

% cat /proc/asound/pcm

With kernels >= 6.7.0 (example :
https://gist.github.com/SR-G/0e86d917716acff0d31cad0365f0b500#file-dmesg-6-12-6-log)
:

% cat /proc/asound/pcm
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1

It seems i'm the only one impacted :(

Who can help me on this topic ?

Thanks in advance and regards.

--
Serge.

On Mon, Feb 5, 2024 at 8:35 AM Linux regression tracking (Thorsten
Leemhuis) <[email-masked]> wrote:
>
> On 05.02.24 08:09, Serge SIMON wrote:
> >
> > Any news on this ?
>
> Apparently not. I added the sound maintainers just to be sure they are
> aware of this.
>
> > Just to say that i tried the 6.7.3 version and i have the exact same
> > problem as described below
> > ("linux-headers-6.7.3.arch1-2-x86_64.pkg.tar.zst" for the exact ARCH
> > package, of course with a system fully up-to-date and rebooted) : no
> > more S/PDIF device detected after reboot (only the monitors are
> > detected, but not anymore the S/PDIF output at motherboard level-
> > which is what i'm using).
> >
> > Reverting to 6.6.10 does solve the issue, so per what i'm seeing,
> > something has definitely been broken between 6.6.10 and 6.7.0 on that
> > topic.
>
> Unless the sound maintainers come up with something, we most likely need
> a bisection from you to resolve this.
>
> In case you want to perform a bisection, this guide I'm currently
> working on might help:
>
> https://www.leemhuis.info/files/misc/How%20to%20bisect%20a%20Linux%20kernel%20regression%20%e2%80%94%20The%20Linux%20Kernel%20documentation.html
>
> > Is this tracked by a bug somewhere ? Does i have to open one (in
> > addition to these mails) ?
>
> No, this thread (for now) is enough.
>
> Ciao, Thorsten
>
>
> > On Wed, Jan 17, 2024 at 6:39 AM Greg KH <[email-masked]> wrote:
> >>
> >> On Tue, Jan 16, 2024 at 09:49:59PM +0100, Serge SIMON wrote:
> >>> Dear Kernel maintainers,
> >>>
> >>> I think i'm encountering (for the first time in years !) a regression
> >>> with the "6.7.arch3-1" kernel (whereas no issues with
> >>> "6.6.10.arch1-1", on which i reverted).
> >>>
> >>> I'm running a (up-to-date, and non-LTS) ARCHLINUX desktop, on a ASUS
> >>> B560-I motherboard, with 3 monitors (attached to a 4-HDMI outputs
> >>> card), plus an audio S/PDIF optic output at motherboard level.
> >>>
> >>> With the latest kernel, the S/PIDF optic output of the motherboard is
> >>> NOT detected anymore (and i haven't been able to see / find anything
> >>> in the logs at quick glance, neither journalctl -xe nor dmesg).
> >>>
> >>> Once reverted to 6.6.10, everything is fine again.
> >>>
> >>> For example, in a working situation (6.6.10), i have :
> >>>
> >>> cat /proc/asound/pcm
> >>> Whereas while on the latest 6.7 kernel, i only had the 4 HDMI lines
> >>> (linked to a NVIDIA T600 card, with 4 HDMI outputs) and not the three
> >>> first ones (attached to the motherboard).
> >>>
> >>> (of course i did several tests with 6.7, reboot, ... without any changes)
> >>>
> >>> Any idea ?
> >>
> >> As this is a sound issue, perhaps send this to the
> >> [email-masked] mailing list (now added).
> >>
> >> Any chance you can do a 'git bisect' between 6.6 and 6.7 to track down
> >> the issue?  Or maybe the sound developers have some things to ask about
> >> as there are loads of debugging knobs in sound...
> >>
> >> thanks,
> >>
> >> greg k-h
> >
> >
>