Subject: Re: [PATCH 1/2] clk: qcom: Fix SM_VIDEOCC_6350 dependencies

From: Imran Shaik <[email-masked]>
Date: Wed, 1 Oct 2025 12:33:03 +0530

On 10/1/2025 12:26 AM, Nathan Chancellor wrote:
> It is possible to select CONFIG_SM_GCC_6350 when targeting ARCH=arm,
> causing a Kconfig warning when selecting CONFIG_SM_GCC_6350 without
> its dependencies, CONFIG_ARM64 or CONFIG_COMPILE_TEST.
> 
>   WARNING: unmet direct dependencies detected for SM_GCC_6350
>     Depends on [n]: COMMON_CLK [=y] && COMMON_CLK_QCOM [=m] && (ARM64 || COMPILE_TEST [=n])
>     Selected by [m]:
>     - SM_VIDEOCC_6350 [=m] && COMMON_CLK [=y] && COMMON_CLK_QCOM [=m]
> 
> Add the same dependency to clear up the warning.
> 
> Cc: [email-masked]
> Fixes: 720b1e8f2004 ("clk: qcom: Add video clock controller driver for SM6350")
> Signed-off-by: Nathan Chancellor <[email-masked]>
> ---
>  drivers/clk/qcom/Kconfig | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/clk/qcom/Kconfig b/drivers/clk/qcom/Kconfig
> index 78a303842613..ec7d1a9b578e 100644
> --- a/drivers/clk/qcom/Kconfig
> +++ b/drivers/clk/qcom/Kconfig
> @@ -1448,6 +1448,7 @@ config SA_VIDEOCC_8775P
>  
>  config SM_VIDEOCC_6350
>  	tristate "SM6350 Video Clock Controller"
> +	depends on ARM64 || COMPILE_TEST
>  	select SM_GCC_6350
>  	select QCOM_GDSC
>  	help
> 

Reviewed-by: Imran Shaik <[email-masked]>

Thanks,
Imran

---

From: Imran Shaik <[email-masked]>
Date: Wed, 1 Oct 2025 12:34:26 +0530

On 10/1/2025 12:26 AM, Nathan Chancellor wrote:
> It is possible to select CONFIG_QCS_{DISP,GPU,VIDEO}CC_615 when
> targeting ARCH=arm, causing a Kconfig warning when selecting
> CONFIG_QCS_GCC_615 without its dependencies, CONFIG_ARM64 or
> CONFIG_COMPILE_TEST.
> 
>   WARNING: unmet direct dependencies detected for QCS_GCC_615
>     - QCS_DISPCC_615 [=m] && COMMON_CLK [=y] && COMMON_CLK_QCOM [=m]
>     - QCS_GPUCC_615 [=m] && COMMON_CLK [=y] && COMMON_CLK_QCOM [=m]
>     - QCS_VIDEOCC_615 [=m] && COMMON_CLK [=y] && COMMON_CLK_QCOM [=m]
> 
> Add the same dependency to these configurations to clear up the
> warnings.
> 
> Fixes: 9b47105f5434 ("clk: qcom: dispcc-qcs615: Add QCS615 display clock controller driver")
> Fixes: f4b5b40805ab ("clk: qcom: gpucc-qcs615: Add QCS615 graphics clock controller driver")
> Fixes: f6a8abe0cc16 ("clk: qcom: videocc-qcs615: Add QCS615 video clock controller driver")
>  drivers/clk/qcom/Kconfig | 3 +++
>  1 file changed, 3 insertions(+)
>

Thanks,
Imran

---

From: Nathan Chancellor <[email-masked]>
Date: Tue, 30 Sep 2025 11:56:09 -0700

diff --git a/drivers/clk/qcom/Kconfig b/drivers/clk/qcom/Kconfig
index ec7d1a9b578e..6fef0bfc1773 100644
--- a/drivers/clk/qcom/Kconfig
+++ b/drivers/clk/qcom/Kconfig
@@ -531,6 +531,7 @@ config QCM_DISPCC_2290
 
 config QCS_DISPCC_615
 	tristate "QCS615 Display Clock Controller"
+	depends on ARM64 || COMPILE_TEST
 	select QCS_GCC_615
 	help
 	  Support for the display clock controller on Qualcomm Technologies, Inc
@@ -586,6 +587,7 @@ config QCS_GCC_615
 
 config QCS_GPUCC_615
 	tristate "QCS615 Graphics clock controller"
+	depends on ARM64 || COMPILE_TEST
 	select QCS_GCC_615
 	help
 	  Support for the graphics clock controller on QCS615 devices.
@@ -594,6 +596,7 @@ config QCS_GPUCC_615
 
 config QCS_VIDEOCC_615
 	tristate "QCS615 Video Clock Controller"
+	depends on ARM64 || COMPILE_TEST
 	select QCS_GCC_615
 	help
 	  Support for the video clock controller on QCS615 devices.

-- 
2.51.0

---

From: Dmitry Baryshkov <[email-masked]>
Date: Tue, 30 Sep 2025 22:14:05 +0300

> Add the same dependency to clear up the warning.

Reviewed-by: Dmitry Baryshkov <[email-masked]>

-- 
With best wishes
Dmitry

---

From: Dmitry Baryshkov <[email-masked]>
Date: Tue, 30 Sep 2025 22:14:25 +0300

-- 
With best wishes
Dmitry

---

From: Nathan Chancellor <[email-masked]>
Date: Tue, 30 Sep 2025 11:56:07 -0700

Hi all,

This series resolves two new Kconfig warnings that I see in my test
framework from an ARM configuration getting bumped to 6.17 and enabling
these configurations in the process.

---
Nathan Chancellor (2):
      clk: qcom: Fix SM_VIDEOCC_6350 dependencies
      clk: qcom: Fix dependencies of QCS_{DISP,GPU,VIDEO}CC_615

 drivers/clk/qcom/Kconfig | 4 ++++
 1 file changed, 4 insertions(+)
---
base-commit: 30bf3ec8cb6b2d2e2f8715388395cbd27cbe4fc9
change-id: 20250930-clk-qcom-kconfig-fixes-arm-3611dec03c3e

Best regards,
--  
Nathan Chancellor <[email-masked]>

---

From: Nathan Chancellor <[email-masked]>
Date: Tue, 30 Sep 2025 11:56:08 -0700

config SM_VIDEOCC_6350

-- 
2.51.0