Subject: Re: Re: Patch "LoongArch: Handle jump tables options for RUST" has been added to the 6.16-stable tree

From: Greg KH <[email-masked]>
Date: Fri, 3 Oct 2025 14:56:15 +0200

On Thu, Oct 02, 2025 at 11:13:22PM +0800, 陈华才 wrote:
> 
> 
> 
> > -----原始邮件-----
> > 发件人: "Miguel Ojeda" <[email-masked]>
> > 发送时间:2025-10-02 01:39:25 (星期四)
> > 收件人: [email-masked]
> > 抄送: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> > 主题: Re: Patch "LoongArch: Handle jump tables options for RUST" has been added to the 6.16-stable tree
> > 
> > On Sun, Sep 21, 2025 at 3:05 PM <[email-masked]> wrote:
> > >
> > > This is a note to let you know that I've just added the patch titled
> > >
> > >     LoongArch: Handle jump tables options for RUST
> > >
> > > to the 6.16-stable tree which can be found at:
> > >     http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary
> > 
> > ...
> > 
> > > commit 74f8295c6fb8436bec9995baf6ba463151b6fb68 upstream.
> > 
> > Huacai et al.: I wonder if we could get this one into 6.12.y?
> I agree with you, it is better to backport to 6.12.y. But it needs
> "LoongArch: Make LTO case independent in Makefile" as its dependency,
> and need "LoongArch: Fix build error for LTO with LLVM-18" as a further
> fix.

Great, can someone send me backported versions of these please?

> 本邮件及其附件含有龙芯中科的商业秘密信息，仅限于发送给上面地址中列出的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制或散发）本邮件及其附件中的信息。如果您错收本邮件，请您立即电话或邮件通知发件人并删除本邮件。 
> This email and its attachments contain confidential information from Loongson Technology , which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it. 
> 
>

Note, this doesn't work for public emails :)

thanks,

greg k-h

---

From: 陈华才 <[email-masked]>
Date: Thu, 2 Oct 2025 23:13:22 +0800 (GMT+08:00)

Huacai

> 
> Maybe no one actually cares in practice, so please feel free to ignore
> it, but it is the only `objtool` warning (a lot of instances, but just
> that kind from a quick look) I have in my LoongArch Rust builds I have
> in 6.12.y, and it would be nice to have it clean.
> 
> Thanks!
> 
> Cheers,
> Miguel

---

From: Miguel Ojeda <[email-masked]>
Date: Wed, 1 Oct 2025 19:39:25 +0200

...

Thanks!

Cheers,
Miguel