Subject: Re: [PATCH] ASoC: SOF: ipc3-topology: Fix multi-core and static pipelines tear down

From: Mark Brown <[email-masked]>
Date: Thu, 02 Oct 2025 18:06:48 +0100

On Thu, 02 Oct 2025 10:31:25 +0300, Peter Ujfalusi wrote:
> In the case of static pipelines, freeing the widgets in the pipelines
> that were not suspended after freeing the scheduler widgets results in
> errors because the secondary cores are powered off when the scheduler
> widgets are freed. Fix this by tearing down the leftover pipelines before
> powering off the secondary cores.
> 
> 
> [...]

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: SOF: ipc3-topology: Fix multi-core and static pipelines tear down
      commit: 59abe7bc7e7c70e9066b3e46874d1b7e6a13de14

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

---

From: Peter Ujfalusi <[email-masked]>
Date: Thu, 2 Oct 2025 10:31:25 +0300

From: Ranjani Sridharan <[email-masked]>

Cc: [email-masked]
Fixes: d7332c4a4f1a ("ASoC: SOF: ipc3-topology: Fix pipeline tear down logic")
Signed-off-by: Ranjani Sridharan <[email-masked]>
Reviewed-by: Péter Ujfalusi <[email-masked]>
Reviewed-by: Kai Vehmanen <[email-masked]>
Signed-off-by: Peter Ujfalusi <[email-masked]>
---
 sound/soc/sof/ipc3-topology.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/sound/soc/sof/ipc3-topology.c b/sound/soc/sof/ipc3-topology.c
index 473d416bc910..f449362a2905 100644
--- a/sound/soc/sof/ipc3-topology.c
+++ b/sound/soc/sof/ipc3-topology.c
@@ -2473,11 +2473,6 @@ static int sof_ipc3_tear_down_all_pipelines(struct snd_sof_dev *sdev, bool verif
 	if (ret < 0)
 		return ret;
 
-	/* free all the scheduler widgets now */
-	ret = sof_ipc3_free_widgets_in_list(sdev, true, &dyn_widgets, verify);
-	if (ret < 0)
-		return ret;
-
 	/*
 	 * Tear down all pipelines associated with PCMs that did not get suspended
 	 * and unset the prepare flag so that they can be set up again during resume.
@@ -2493,6 +2488,11 @@ static int sof_ipc3_tear_down_all_pipelines(struct snd_sof_dev *sdev, bool verif
 		}
 	}
 
+	/* free all the scheduler widgets now. This will also power down the secondary cores */
+	ret = sof_ipc3_free_widgets_in_list(sdev, true, &dyn_widgets, verify);
+	if (ret < 0)
+		return ret;
+
 	list_for_each_entry(sroute, &sdev->route_list, list)
 		sroute->setup = false;
 
-- 
2.51.0