Subject: Re: License and questions regarding gnome-printing

From: Luna Jernberg <[email-masked]>
Date: Thu, 19 Jun 2025 16:51:48 +0200

Alright will do

Den tors 19 juni 2025 kl 16:50 skrev Ole Aamot <[email-masked]>:
>
> Delete gnome-printing from AUR.  It is obsolete and not necessary for printing on GNOME Systems.
>
> On 6/19/25 10:00 AM, Ole Aamot wrote:
>
> Hello,
>
> Thank you for your message and for raising these important questions regarding the gnome-printing package recently submitted to the AUR.
>
> I'll address both of your concerns directly:
>
>
> ---
>
> 1. License of gnome-printing
>
> The license for gnome-printing was initially not clearly stated, and I understand this has caused confusion. To clarify:
>
> The gnome-printing project is an experimental wrapper intended to integrate simplified printing functionality for specific GTK4/GNOME4-based workflows.
>
> It was developed under the principles of free and open-source software, and the intention is to license it under the Public Domain, in line with most GNOME utilities.
>
> The license declaration was inadvertently omitted from the initial release, and we will be adding a COPYING file and SPDX license headers in the next version update on https://github.com/aamotsoftware/printing to make this explicit.
>
>
>
> ---
>
> 2. Purpose of gnome-printing
>
> You are absolutely right that GNOME uses CUPS for its built-in printing system. gnome-printing is not a replacement for CUPS or for GNOME's existing print stack. Instead, its goals are:
>
> To provide a user-facing frontend (using GTK4/Adwaita) for certain common printing tasks, primarily aimed at developers and tinkerers who want tighter scripting or sandboxed integration (such as within GNOME Builder or Flatpak applications).
>
> It acts as a thin wrapper around CUPS and the common UNIX lp/lpr utilities, with potential features like:
>
> previewing print jobs via a minimal UI,
>
> generating print-ready PDFs,
>
> selecting specific backends or printers in a streamlined way (especially for headless usage or kiosk setups),
>
> integration with non-CUPS pipelines (future potential, e.g., IPP-over-USB experiments).
>
>
>
> That said, it is indeed redundant for general GNOME desktop users, who already benefit from excellent support via the gnome-control-center and evince/gtk-print stack. As such, gnome-printing is niche and optional, meant more for experimentation and lightweight print job scripting in specific GNOME developer scenarios.
>
> See https://www.aamot.org/ole/printing.html
> ---
>
> Next Steps
>
> We will:
>
> Update the project metadata with the correct license information.
>
> Clarify the purpose and scope of the package in the AUR description and upstream README to avoid misunderstandings.
>
> Ensure FabioLolix’s fixes are merged and credited.
>
> Could you provide me with FabioLolix's fixes?
>
> ---
>
> Thanks again for your diligence, and we appreciate the Arch community’s attention to detail and software quality.
>
> Warm regards,
> Ole Kristian Aamot
> Aamot Research
> [email-masked]
> www.aamot.io
>
> — cc: Luna (“bittin”), FabioLolix, Muflone
>
>
> On Thu, Jun 19, 2025, 7:31 AM Chloe <[email-masked]> wrote:
>>
>> Hello,
>>
>> A few days ago, an AUR user bittin ("Luna") submitted the gnome-printing package to AUR and they signed off their emails with "Luna <on behalf
>> of Ole>".
>>
>> Community members have raised several issues with the package. While the build script has been mostly fixed (courtesy of FabioLolix), there are
>> still some questions:
>>
>> 1. What is the license of gnome-printing? We are unable to find the license, and therefore it is uncertain whether this software can be
>> redistributed.
>> 2. What is the purpose of gnome-printing? Muflone, who is a Package Maintainer (an official Arch Linux staff role), has pointed out that "GNOME
>> has builtin printing system using CUPS". Does gnome-printing provide any feature which cannot be satisfied by GNOME's builtin features or other
>> existing software?
>>
>> Regards,
>> gnlrdrvo

---

From: Luna Jernberg <[email-masked]>
Date: Thu, 19 Jun 2025 16:52:58 +0200

https://lists.archlinux.org/archives/list/[email-masked]/thread/UWP5QZPZEEPPDAXQFRHUJ7Y3MN37QAEI/

---

From: Luna Jernberg <[email-masked]>
Date: Thu, 19 Jun 2025 19:11:02 +0200

The package is now deleted